<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Khabib says he’s ready for Ferguson if they can just give him an address</title>
<link rel='dns-prefetch' href='//widget.ranker.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Pro MMA Now &raquo; Feed" href="https://prommanow.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Pro MMA Now &raquo; Comments Feed" href="https://prommanow.com/comments/feed/" />
<meta name="description" content="This is getting ridiculous. UFC 249 is probably going to be held in someone’s basement. This coronavirus pandemic isn’t messing around. Dana White has been..." />
<link rel="alternate" type="application/rss+xml" title="Pro MMA Now &raquo; Khabib says he’s ready for Ferguson if they can just give him an address Comments Feed" href="https://prommanow.com/2020/03/24/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address/feed/" />
<meta name="keywords" content="coronavirus, Dana White, khabib nurmagomedov, Tony Ferguson, UFC 249" />
<meta name="robots" content="index,follow,noodp,noydir" />
<link rel="canonical" href="https://prommanow.com/2020/03/24/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/prommanow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://prommanow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='SFSImainCss-css'  href='https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/css/sfsi-style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='https://prommanow.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='https://prommanow.com/wp-content/themes/generatepress/style.min.css?ver=2.4.1' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='https://prommanow.com/wp-content/themes/generatepress/css/mobile.min.css?ver=2.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://prommanow.com/wp-content/themes/generatepress/css/font-awesome.min.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-css'  href='https://prommanow.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sticky-css'  href='https://prommanow.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sticky.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-menu-logo-css'  href='https://prommanow.com/wp-content/plugins/gp-premium/menu-plus/functions/css/menu-logo.min.css?ver=1.9.1' type='text/css' media='all' />
<style id='generate-menu-logo-inline-css' type='text/css'>
@media (max-width: 768px){.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo .main-navigation:not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.sticky-menu-logo .navigation-stick:not(.mobile-header-navigation) .mobile-bar-items,.menu-logo .main-navigation:not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{display:inline-block;clear:none;width:auto;float:right;}.regular-menu-logo .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .mobile-bar-items{position:relative;float:right;}body[class*="nav-float-"].menu-logo-enabled:not(.sticky-menu-logo) .main-navigation .main-nav{display:block;}.sticky-menu-logo.nav-float-left .navigation-stick:not(.mobile-header-navigation) .menu-toggle,.menu-logo.nav-float-left .main-navigation:not(.mobile-header-navigation) .menu-toggle,.regular-menu-logo.nav-float-left .main-navigation:not(.navigation-stick):not(.mobile-header-navigation) .menu-toggle{float:left;}}
</style>
<script type='text/javascript' src='https://prommanow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://prommanow.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://prommanow.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://prommanow.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://prommanow.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='With new ATT conduct policy Joanna Jedrzejczyk says Colby Covington should be ejected' href='https://prommanow.com/2020/03/24/with-new-att-conduct-policy-joanna-jedrzejczyk-says-colby-covington-should-be-ejected/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://prommanow.com/?p=168123' />
<link rel="alternate" type="application/json+oembed" href="https://prommanow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprommanow.com%2F2020%2F03%2F24%2Fkhabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://prommanow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprommanow.com%2F2020%2F03%2F24%2Fkhabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address%2F&#038;format=xml" />
<!-- Start DFP SETUP -->
<script type="text/javascript"><!--
//<![CDATA[
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
//]]>
//--></script>
<script type='text/javascript' src='https://img.bnqt.com/lib/js/sdpdfphelper.js'></script>
<script type="text/javascript">
googletag.pubads().collapseEmptyDivs(); 
googletag.pubads().enableSyncRendering();
googletag.pubads().setTargeting("title", sdpTargeting.title)
                  .setTargeting('targetPaths', sdpTargeting.targetPaths)
                  .setTargeting('fullPath', sdpTargeting.fullPath)
                  .setTargeting('queryStr', sdpTargeting.queryStr)
                  .setTargeting('domainName', sdpTargeting.domainName);       
</script>
<!-- End DFP SETUP -->  

<meta name="google-site-verification" content="tng3K_Q6cSfv1AFw1jUz5JulOiy1LpK4PDrzyVAUqx4" />
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-9839086-2']);
  _gaq.push(['_setDomainName', 'prommanow.com']);
  _gaq.push(['_setAllowLinker', true]);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<link href='http://fonts.googleapis.com/css?family=Oswald:700,400' rel='stylesheet' type='text/css'>

<meta name="alexaVerifyID" content="kETqBbyDwu1rPl_vZ2RSj0V2Ebw"/>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8790870466166310",
    enable_page_level_ads: true
  });
</script><meta name="specificfeeds-verification-code-TXlFS3hNazA4eUM3NWhUQm9zU0lXeDltMUpEa1FLOTRSRFU3TUVlMjBOaGdDUTV2QUtoeVRvRVE5amVGeW5tR0s0U3I5amVGK255QXVFTGt6ZjhhOW9yT002YVBaUkIzZFQyTGFHRGZrTHJzSVpEQnZkVWx1QXlvWk1nL1JxVVd8SEdDVE8zSm5EM2JGMmJPVjhTQTNPRk94M2cxQ25lZCtVa3FnMWx4cGtJMD0=" content="UvCqqTsQ7AHjJ6H1QTJC"/><script type='text/javascript'>/* <![CDATA[ */ var _wpaudio = {url: 'https://prommanow.com/wp-content/plugins/wpaudio-mp3-player', enc: {}, convert_mp3_links: false, style: {text_font:'Sans-serif',text_size:'18px',text_weight:'normal',text_letter_spacing:'normal',text_color:'inherit',link_color:'#24f',link_hover_color:'#02f',bar_base_bg:'#eee',bar_load_bg:'#ccc',bar_position_bg:'#46f',sub_color:'#aaa'}}; /* ]]> */</script><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="icon" href="https://prommanow.com/wp-content/uploads/2013/01/prommaicon-55x55.png" sizes="32x32" />
<link rel="icon" href="https://prommanow.com/wp-content/uploads/2013/01/prommaicon.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://prommanow.com/wp-content/uploads/2013/01/prommaicon.png" />
<meta name="msapplication-TileImage" content="https://prommanow.com/wp-content/uploads/2013/01/prommaicon.png" />
</head>

<body class="post-template-default single single-post postid-168123 single-format-standard wp-custom-logo wp-embed-responsive post-image-above-header post-image-aligned-center sticky-menu-fade sticky-enabled regular-menu-logo menu-logo-enabled both-sticky-menu both-sidebars nav-below-header contained-header one-container active-footer-widgets-0 nav-search-enabled nav-aligned-left header-aligned-center dropdown-hover featured-image-active" itemtype="https://schema.org/Blog" itemscope>
	<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>		<div class="top-bar top-bar-align-right">
			<div class="inside-top-bar grid-container grid-parent">
				<aside id="text-633350485" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="mailto:prommanow@gmail.com">Contact Us</a></p>
</div>
		</aside>			</div>
		</div>
				<header id="masthead" class="site-header grid-container grid-parent" itemtype="https://schema.org/WPHeader" itemscope>
			<div class="inside-header grid-container grid-parent">
				<div class="site-branding">
					
					<p class="site-description" itemprop="description">
				The Independent Voice of Mixed Martial Arts
			</p>
				</div><div class="site-logo">
				<a href="https://prommanow.com/" title="Pro MMA Now" rel="home">
					<img  class="header-image" alt="Pro MMA Now" src="https://prommanow.com/wp-content/uploads/2017/07/prommanow_logo_350x70.png" title="Pro MMA Now" />
				</a>
			</div><p>
<center><a href="https://sports.betway.com/en/sports" target="_blank" rel="noopener"><img src="https://prommanow.com/wp-content/uploads/2019/07/betting-site-betway-logo-white.jpg" alt="Online Betting site Betway"></a></center>			</div><!-- .inside-header -->
		</header><!-- #masthead -->
				<nav id="site-navigation" class="main-navigation" itemtype="https://schema.org/SiteNavigationElement" itemscope>
			<div class="inside-navigation grid-container grid-parent">
				<div class="site-logo sticky-logo navigation-logo">
				<a href="https://prommanow.com/" title="Pro MMA Now" rel="home">
					<img src="https://prommanow.com/wp-content/uploads/2013/01/prommaicon.png" alt="Pro MMA Now" />
				</a>
			</div><form method="get" class="search-form navigation-search" action="https://prommanow.com/">
				<input type="search" class="search-field" value="" name="s" title="Search" />
			</form>		<div class="mobile-bar-items">
						<span class="search-item">
				<a aria-label="Open Search Bar" href="#">
									</a>
			</span>
		</div><!-- .mobile-bar-items -->
						<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
					<span class="mobile-menu">Menu</span>				</button>
				<div id="primary-menu" class="main-nav"><ul id="menu-main-menu" class=" menu sf-menu"><li id="menu-item-106107" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-106107"><a href="https://prommanow.com">Home</a></li>
<li id="menu-item-146223" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146223"><a href="https://prommanow.com/category/mma/">MMA</a></li>
<li id="menu-item-161464" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161464"><a href="https://prommanow.com/tag/ufc-odds">UFC Odds</a></li>
<li id="menu-item-161463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161463"><a href="https://prommanow.com/category/boxing/">Boxing</a></li>
<li id="menu-item-161465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161465"><a href="https://prommanow.com/tag/boxing-odds">Boxing Odds</a></li>
<li id="menu-item-146105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146105"><a href="https://prommanow.com/category/wwe-2/">WWE</a></li>
<li id="menu-item-166777" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-166777"><a href="https://prommanow.com/category/sports-2/">Sports</a></li>
<li id="menu-item-162834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162834"><a href="https://prommanow.com/category/fitness-2/">Fitness</a></li>
<li id="menu-item-167198" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-167198"><a href="http://progamesnow.com">Gaming</a></li>
<li id="menu-item-161542" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161542"><a href="https://www.facebook.com/ProMMANow/"><i class="fa fa-facebook-square" aria-hidden="true"></i></a></li>
<li id="menu-item-161543" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161543"><a href="http://twitter.com/promma"><i class="fa fa-twitter" aria-hidden="true"></i></a></li>
<li class="search-item"><a aria-label="Open Search Bar" href="#"></a></li></ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #site-navigation -->
		
	<div id="page" class="hfeed site grid-container container grid-parent">
				<div id="content" class="site-content">
			
	<div id="primary" class="content-area grid-parent mobile-grid-100 push-25 grid-50 tablet-push-25 tablet-grid-50">
		<main id="main" class="site-main">
			
<article id="post-168123" class="post-168123 post type-post status-publish format-standard has-post-thumbnail hentry category-ufc tag-coronavirus tag-dana-white tag-khabib-nurmagomedov tag-tony-ferguson tag-ufc-249" itemtype="https://schema.org/CreativeWork" itemscope>
	<div class="inside-article">
		<div class="featured-image  page-header-image-single ">
			<img width="400" height="300" src="https://prommanow.com/wp-content/uploads/2020/02/3EE160FB-836B-4BBE-9F91-732962CC693E.jpeg" class="attachment-full size-full" alt="" itemprop="image" />
		</div>
		<header class="entry-header">
			<h1 class="entry-title" itemprop="headline">Khabib says he’s ready for Ferguson if they can just give him an address</h1>			<div class="entry-meta">
				<span class="posted-on"><a href="https://prommanow.com/2020/03/24/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address/" title="10:08 pm" rel="bookmark"><time class="updated" datetime="2020-03-24T22:08:48-06:00" itemprop="dateModified">March 24, 2020</time><time class="entry-date published" datetime="2020-03-24T22:08:46-06:00" itemprop="datePublished">March 24, 2020</time></a></span> <span class="byline">by <span class="author vcard" itemprop="author" itemtype="https://schema.org/Person" itemscope><a class="url fn n" href="https://prommanow.com/author/sean-mcclure/" title="View all posts by Sean McClure" rel="author" itemprop="url"><span class="author-name" itemprop="name">Sean McClure</span></a></span></span> 			</div><!-- .entry-meta -->
				</header><!-- .entry-header -->

		
		<div class="entry-content" itemprop="text">
			
<p>This is getting ridiculous. UFC 249 is probably going to be held in someone’s basement. This coronavirus pandemic isn’t messing around.<br></p>



<p>Dana White has been all over the news first with news of a venue for the event then the next day he’s uncertain if it will even take place. Imagine being the two best lightweights in the world trying to settle the argument of who is the top dog and your biggest challenge isn’t your opponent it’s a worldwide pandemic. Lightweight champion Khabib Nurmagomedov and former interim champ Tony Ferguson have been staking their claim at who the real number one is.</p>



<p>I am one of those people dying to know the answer to that question but it is not worth people dying over.</p>



<p>Since the ban on events has been implemented there have been empty arena scenarios but even those are being shut down. Dana has been trying to play out every possible scenario and it doesn’t seem to be working. We heard rumors of tribal lands, empty arenas, training centers, and some that are too ridiculous to repeat. The UFC President came out today stating that he had a location that he might be able to pull off but he didn’t want to say yet.<br></p>



<p>Imagine being Khabib and Tony prepping for what should be a big money fight only to have the news broken to you about all of the challenges they are facing. This bout has been called cursed because it has been canceled several times before this for one reason or another. There is a positive and that is both combatants are still training like it’s going to go down somewhere. Maybe there’s hope?</p>



<p>Here’s what Nurmagomedov posted earlier.</p>



<figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper">
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B-HAfaClkhf/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B-HAfaClkhf/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B-HAfaClkhf/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">В ожидании локации 📍#ufc249 We all waiting for location &#8230;. @bukaboxing</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/khabib_nurmagomedov/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Khabib Nurmagomedov</a> (@khabib_nurmagomedov) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-03-24T08:21:39+00:00">Mar 24, 2020 at 1:21am PDT</time></p></div></blockquote>
<script async src="//www.instagram.com/embed.js"></script>
</div></figure>



<p>I am praying to the MMA gods that this happens somewhere even if it’s a broom closet. </p>
<div class='sfsi_Sicons' style='width: 100%; display: inline-block; vertical-align: middle; text-align:left'><div style='margin:0px 8px 0px 0px; line-height: 24px'><span>Please like & share:</span></div><div class='sfsi_socialwpr'><div class='sf_subscrbe' style='text-align:left;vertical-align: middle;float:left;width:64px'><a href="http://www.specificfeeds.com/widgets/emailSubscribeEncFeed/TXlFS3hNazA4eUM3NWhUQm9zU0lXeDltMUpEa1FLOTRSRFU3TUVlMjBOaGdDUTV2QUtoeVRvRVE5amVGeW5tR0s0U3I5amVGK255QXVFTGt6ZjhhOW9yT002YVBaUkIzZFQyTGFHRGZrTHJzSVpEQnZkVWx1QXlvWk1nL1JxVVd8SEdDVE8zSm5EM2JGMmJPVjhTQTNPRk94M2cxQ25lZCtVa3FnMWx4cGtJMD0=/OA==/" target="_blank"><img src="https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/images/follow_subscribe.png" alt="error" /></a></div><div class='sf_fb' style='text-align:left;vertical-align: middle;width:98px'><div class="fb-like" data-href="https://prommanow.com/2020/03/24/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address/" data-width="180" data-send="false" data-show-faces="false"  data-action="like" data-share="true"data-layout="button" ></div></div><div class='sf_twiter' style='text-align:left;float:left;vertical-align: middle;width:auto'><a href="http://twitter.com/share" data-count="none" class="sr-twitter-button twitter-share-button" lang="en" data-url="https://prommanow.com/2020/03/24/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address/" data-text="Khabib says he’s ready for Ferguson if they can just give him an address" ></a></div></div></div>		</div><!-- .entry-content -->

					<footer class="entry-meta">
				<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="https://prommanow.com/category/ufc/" rel="category tag">UFC</a></span> <span class="tags-links"><span class="screen-reader-text">Tags </span><a href="https://prommanow.com/tag/coronavirus/" rel="tag">coronavirus</a>, <a href="https://prommanow.com/tag/dana-white/" rel="tag">Dana White</a>, <a href="https://prommanow.com/tag/khabib-nurmagomedov/" rel="tag">khabib nurmagomedov</a>, <a href="https://prommanow.com/tag/tony-ferguson/" rel="tag">Tony Ferguson</a>, <a href="https://prommanow.com/tag/ufc-249/" rel="tag">UFC 249</a></span> 		<nav id="nav-below" class="post-navigation">
			<span class="screen-reader-text">Post navigation</span>

			<div class="nav-previous"><span class="prev" title="Previous"><a href="https://prommanow.com/2020/03/24/with-new-att-conduct-policy-joanna-jedrzejczyk-says-colby-covington-should-be-ejected/" rel="prev">With new ATT conduct policy Joanna Jedrzejczyk says Colby Covington should be ejected</a></span></div>		</nav><!-- #nav-below -->
					</footer><!-- .entry-meta -->
			</div><!-- .inside-article -->
</article><!-- #post-## -->

					<div class="comments-area">
						
<div id="disqus_thread"></div>
					</div>

							</main><!-- #main -->
	</div><!-- #primary -->

	<div id="left-sidebar" class="widget-area grid-25 tablet-grid-25 mobile-grid-100 grid-parent sidebar pull-50 tablet-pull-50" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-left-sidebar">
		<aside id="text-633350484" class="widget inner-padding widget_text">			<div class="textwidget"><p><center><a href="https://www.couponsplusdeals.com/category/sporting-goods">Sporting Deals and Discount with Coupons Plus Deals</a></center></p>
</div>
		</aside><aside id="text-633350476" class="widget inner-padding widget_text">			<div class="textwidget"><p><center><a href="http://www.7binaryoptions.com/iqoption-review/">Binary options broker review: IQ Option</a></center></p>
</div>
		</aside><aside id="text-633350477" class="widget inner-padding widget_text">			<div class="textwidget"><p><center><a href="https://searchpromocodes.com/category/sports-entertainment">Sporting goods deals available @SearchPromoCodes</a></center></p>
</div>
		</aside><aside id="text-633350488" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="http://www.centrapeak.com/"><img src="https://prommanow.com/wp-content/uploads/2019/05/Banner-300-250.jpg"></a></p>
</div>
		</aside>	</div><!-- .inside-left-sidebar -->
</div><!-- #secondary -->
<div id="right-sidebar" class="widget-area grid-25 tablet-grid-25 grid-parent sidebar" itemtype="https://schema.org/WPSideBar" itemscope>
	<div class="inside-right-sidebar">
		<aside id="text-633350471" class="widget inner-padding widget_text">			<div class="textwidget"><p><!-- SMG_ProMMAnow/300x250_2a/sports/mma/main --></p>
<div id="usmg_ad_main_mma_sports_300x250_2a" class="ads300-250"><script type='text/javascript'>
googletag.defineSlot('/7103/SMG_ProMMAnow/300x250_2a/sports/mma/' + _SitePage, [[300,250],[300,600]], 'usmg_ad_main_mma_sports_300x250_2a').addService(googletag.pubads());
googletag.enableServices();
googletag.display('usmg_ad_main_mma_sports_300x250_2a');
</script></div>
</div>
		</aside><aside id="text-633350493" class="widget inner-padding widget_text">			<div class="textwidget"><p><center>Problems with college essay writing? Essayassist.net <a href="https://essayassist.net/">college essay writing help</a> is what you need.</center></p>
</div>
		</aside>	</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->

	</div><!-- #content -->
</div><!-- #page -->


<div class="site-footer grid-container grid-parent footer-bar-active footer-bar-align-center">
			<footer class="site-info" itemtype="https://schema.org/WPFooter" itemscope>
			<div class="inside-site-info grid-container grid-parent">
						<div class="footer-bar">
			<aside id="text-633350479" class="widget inner-padding widget_text">			<div class="textwidget"><p><a href="mailto:prommanow@gmail.com">Contact Us</a></p>
</div>
		</aside><aside id="text-633350481" class="widget inner-padding widget_text">			<div class="textwidget"><p>Partner with USA TODAY Sports Digital Properties / <a href="https://prommanow.com/advertise/privacy-policy/">Privacy Policy</a></p>
</div>
		</aside>		</div>
						<div class="copyright-bar">
					<span class="copyright">&copy; 2020 Pro MMA Now</span> &bull; Powered by <a href="https://generatepress.com" itemprop="url">GeneratePress</a>				</div>
			</div>
		</footer><!-- .site-info -->
		</div><!-- .site-footer -->

<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
				<span class="screen-reader-text">Scroll back to top</span>
				
			</a>			<!--facebook like and share js -->
			<div id="fb-root"></div>
			<script>
				(function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s);
					js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script>
					<!-- twitter JS End -->
			<script>
				! function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (!d.getElementById(id)) {
						js = d.createElement(s);
						js.id = id;
						js.src = "https://platform.twitter.com/widgets.js";
						fjs.parentNode.insertBefore(js, fjs);
					}
				}(document, "script", "twitter-wjs");
			</script>
		<script>
window.addEventListener('sfsi_functions_loaded', function() {
    if (typeof sfsi_responsive_toggle == 'function') {
        sfsi_responsive_toggle(0);

    }
})
</script>

<script>
    window.addEventListener('sfsi_functions_loaded', function() {
        if (typeof sfsi_plugin_version == 'function') {
            sfsi_plugin_version(2.44);
        }
    });

    function sfsi_processfurther(ref) {

        var feed_id = 'TXlFS3hNazA4eUM3NWhUQm9zU0lXeDltMUpEa1FLOTRSRFU3TUVlMjBOaGdDUTV2QUtoeVRvRVE5amVGeW5tR0s0U3I5amVGK255QXVFTGt6ZjhhOW9yT002YVBaUkIzZFQyTGFHRGZrTHJzSVpEQnZkVWx1QXlvWk1nL1JxVVd8SEdDVE8zSm5EM2JGMmJPVjhTQTNPRk94M2cxQ25lZCtVa3FnMWx4cGtJMD0=';
        var feedtype = 8;

        var email = jQuery(ref).find('input[name="data[Widget][email]"]').val();

        var filter = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;

        if ((email != "Enter your email") && (filter.test(email))) {
            if (feed_id != "") {

                if (feedtype == "8") {

                    var url = "https://www.specificfeeds.com/widgets/subscribeWidget/" + feed_id + "/" + feedtype;

                    window.open('', "popupwindow", "scrollbars=yes,width=1080,height=760");

                    ref.action = url;

                    ref.target = "popupwindow";

                    return true;

                } else {

                    return false

                }
            }
        } else {

            alert("Please enter email address");

            jQuery(ref).find('input[name="data[Widget][email]"]').focus();

            return false;

        }

    }
</script>

<style type="text/css" aria-selected="true">
    .sfsi_subscribe_Popinner {

        width: 100% !important;

        height: auto !important;

        border: 1px solid #b5b5b5 !important;

        padding: 18px 0px !important;

        background-color: #ffffff !important;

    }

    .sfsi_subscribe_Popinner form {

        margin: 0 20px !important;

    }

    .sfsi_subscribe_Popinner h5 {

        font-family: Helvetica,Arial,sans-serif !important;

        font-weight: bold !important;

        color: #000000 !important;

        font-size: 16px !important;

        text-align: center !important;

        margin: 0 0 10px !important;

        padding: 0 !important;

    }

    .sfsi_subscription_form_field {

        margin: 5px 0 !important;

        width: 100% !important;

        display: inline-flex;

        display: -webkit-inline-flex;

    }

    .sfsi_subscription_form_field input {

        width: 100% !important;

        padding: 10px 0px !important;

    }

    .sfsi_subscribe_Popinner input[type=email] {

        font-family: Helvetica,Arial,sans-serif !important;

        font-style: normal !important;

        color: #000000 !important;

        font-size: 14px !important;

        text-align: center !important;

    }

    .sfsi_subscribe_Popinner input[type=email]::-webkit-input-placeholder {

        font-family: Helvetica,Arial,sans-serif !important;

        font-style: normal !important;

        color: #000000 !important;

        font-size: 14px !important;

        text-align: center !important;

    }

    .sfsi_subscribe_Popinner input[type=email]:-moz-placeholder {
        /* Firefox 18- */

        font-family: Helvetica,Arial,sans-serif !important;

        font-style: normal !important;

        color: #000000 !important;

        font-size: 14px !important;

        text-align: center !important;

    }

    .sfsi_subscribe_Popinner input[type=email]::-moz-placeholder {
        /* Firefox 19+ */

        font-family: Helvetica,Arial,sans-serif !important;

        font-style: normal !important;

        color: #000000 !important;

        font-size: 14px !important;

        text-align: center !important;

    }

    .sfsi_subscribe_Popinner input[type=email]:-ms-input-placeholder {

        font-family: Helvetica,Arial,sans-serif !important;

        font-style: normal !important;

        color: #000000 !important;

        font-size: 14px !important;

        text-align: center !important;

    }

    .sfsi_subscribe_Popinner input[type=submit] {

        font-family: Helvetica,Arial,sans-serif !important;

        font-weight: bold !important;

        color: #000000 !important;

        font-size: 16px !important;

        text-align: center !important;

        background-color: #dedede !important;

    }
</style>

<script>var RNKRW = RNKRW || {};RNKRW.pref = {header	: {name		: true,image		: false,username	: false,criteria	: false,bgcolor	: "ffffff",fontface	: "arial",fontcolor	: "000000"},list	: {displaythumbnails	: true,displaydescriptions	: true,slidebgcolor		: "ffffff",fontface			: "arial",fontcolor			: "000000"},footer	: {bgcolor	: "5c5b5b"}};</script>
<script type='text/javascript' src='//widget.ranker.com/static/rnkrw2.js'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/wpaudio-mp3-player/wpaudio.min.js?ver=3.1'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=1.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"prommanow"};
/* ]]> */
</script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"168123 https:\/\/prommanow.com\/?p=168123","disqusShortname":"prommanow","disqusTitle":"Khabib says he\u2019s ready for Ferguson if they can just give him an address","disqusUrl":"https:\/\/prommanow.com\/2020\/03\/24\/khabib-says-hes-ready-for-ferguson-if-they-can-just-give-him-an-address\/","postId":"168123"};
/* ]]> */
</script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://prommanow.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/modernizr.custom.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/jquery.shuffle.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/js/shuffle/random-shuffle-min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sfsi_icon_ajax_object = {"ajax_url":"https:\/\/prommanow.com\/wp-admin\/admin-ajax.php"};
var sfsi_icon_ajax_object = {"ajax_url":"https:\/\/prommanow.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/prommanow.com\/wp-content\/plugins\/ultimate-social-media-icons\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://prommanow.com/wp-content/plugins/ultimate-social-media-icons/js/custom.js?ver=5.3.2'></script>
<!--[if lte IE 11]>
<script type='text/javascript' src='https://prommanow.com/wp-content/themes/generatepress/js/classList.min.js?ver=2.4.1'></script>
<![endif]-->
<script type='text/javascript' src='https://prommanow.com/wp-content/themes/generatepress/js/menu.min.js?ver=2.4.1'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/themes/generatepress/js/a11y.min.js?ver=2.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var generatepressNavSearch = {"open":"Open Search Bar","close":"Close Search Bar"};
/* ]]> */
</script>
<script type='text/javascript' src='https://prommanow.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=2.4.1'></script>
<script type='text/javascript' src='https://prommanow.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=2.4.1'></script>
<script type='text/javascript' src='https://prommanow.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>

</body>
</html>
